CEM Slowness
Incident Report for Paradox
Resolved
This incident has been resolved.
Posted Aug 19, 2024 - 13:37 MST
Investigating
We are currently investigating slowness in our CEM
Posted Aug 19, 2024 - 11:04 MST
This incident affected: Candidate Experience Manager (Candidate Experience).