Issue with Browser Extension

Incident Report for Paradox

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 19:17 MST

Investigating

We are currently investigating an issue that can cause our Browser Extension to fail to load in some instances. More information to follow.
Posted Jun 17, 2026 - 09:49 MST