CEM Slowness

Incident Report for Paradox

Resolved

The slowness affecting the CEM has been resolved, and all operations have returned to normal. We will continue to monitor the system to ensure ongoing stability.
Posted Jul 09, 2026 - 17:35 MST

Investigating

We are investigating slowness in the CEM.
Posted Jul 09, 2026 - 14:12 MST
This incident affected: Candidate Experience Manager (User Experience).