CEM access issues from Comcast

Incident Report for Paradox

Monitoring

Comcast has resolved the issue with routing traffic to our CEM, and users in many regions have regained access. We are still waiting for a full confirmation from Comcast on a resolution.
Posted Jun 26, 2025 - 14:12 MST

Identified

We have been notified that some users are not able to access the CEM. We have determined that this is specific to users with Comcast as their internet provider, and are working with Comcast to resolve.
Posted Jun 25, 2025 - 13:16 MST
This incident affects: Candidate Experience Manager (User Experience).