General Service Slowness

Incident Report for Paradox

Resolved

All residual issues resulting from the AWS outage have been resolved.
Posted Oct 20, 2025 - 21:26 MST

Update

We are continuing to work to full restore services after the AWS outage. During this time some services may continue to be impacted or not available.
Posted Oct 20, 2025 - 19:38 MST

Update

We are continuing to recover systems. Workflows and messages may still be delayed in some cases.
Posted Oct 20, 2025 - 18:09 MST

Identified

We are currently seeing slowness with our services due to the ongoing AWS outage. We are actively working on a resolution.
Posted Oct 20, 2025 - 08:42 MST
This incident affected: Conversations (SMS, Site Widget, WhatsApp, Email, Facebook Messenger), Candidate Experience Manager (Site Services, User Experience, Candidate Experience), Reporting (Reporting), and Integrations (I-9 Services, WOTC Services, Tax Information Services, Traitify Assessment).