CEM Slowness
Incident Report for Paradox
Resolved
A fix has been implemented, and we are monitoring the results.
Posted Aug 07, 2024 - 13:50 MST
Investigating
We are currently investigating slowness that some users are experiencing when using the CEM.
Posted Aug 07, 2024 - 13:13 MST
This incident affected: Candidate Experience Manager (User Experience).