CEM Slowness

Incident Report for Paradox

Resolved

Response times have returned to normal.
Posted Jul 01, 2026 - 13:46 MST

Investigating

We are investigating slowness in the CEM.
Posted Jul 01, 2026 - 12:10 MST
This incident affected: Candidate Experience Manager (User Experience).